Edit Anything

Professional text and hex editing
with Binary Templates technology.






010 Editor - Text/Hex Editor Homepage

The Status Bar, located along the bottom of the application, contains useful information about the current file and the current status of the editor. The Status Bar is divided up into a number of panels and most of these panels can be clicked to either change how information is viewed in the editor or to control what format data is displayed in. Different panels are displayed depending upon which type of file is being edited and the following shows a typical status bar for a Text file on top:

The panels E, F, G, H, I and J may appear or disappear depending upon which Edit As is selected in panel E and the panels for a Hex file are shown in the above figure on the bottom. The following lists the usage of each panel and when it appears:

  • Message Area (A) - Displays information about the last completed operation. When an important message such as an error or warning is displayed in this field, the message will be displayed with an orange background.

  • File Position / Selection Start (B) - When no bytes are selected, this panel shows the current address of the cursor in the file. When bytes are selected, this panel displays 'Start:' followed by the starting address of the selection. The address can display the current byte number, sector number, line number or short number and the address can be displayed in hex format, decimal format, or octal format. Set the address format using the 'View > Status Bar > File Position Units' menu option or left-click on the panel and select File Position Units. Left-click on this panel and select Goto to bring up the Goto bar.


  • Current Byte / Selection Size (C) - When no bytes are selected, this panel displays the current value of the byte the cursor is over. By default the value of the byte is displayed in hex and decimal formats but other formats can be chosen with 'View > Status Bar > Byte Value Units' or by left-clicking on the panel and selecting Byte Value Units. The byte value is displayed as an Unsigned Byte but to convert to other formats see the Inspector. When bytes are selected in the file, this panel displays 'Sel:' followed by the size of the current selection. The display format used for the selection size can be controlled using the 'View > Status Bar > Selection Size Units' menu option or by left-clicking on the panel and choosing Selection Size Units. Note that when displaying the selection size as a number of lines and less than one line is selected, the number of selected bytes will be displayed instead.


  • File Size (D) - Shows the size of the file being edited. The size can be displayed in number of bytes, sectors, lines or shorts and the size can be shown in hex format, decimal format, or octal format. To control the displayed format, see the 'View > Status Bar > File Size Units' menu option or left-click on the panel and choose File Size Units. Note that a '*' will appear beside the file size if the size has been changed since the file was opened. Left-click on this panel and choose Set File Size to open the Set File Size dialog.


  • Edit As (E) - Displays which Edit As is selected for the current file. Which Edit As is chosen determines which of the following Status Bar panels are displayed. Left-click on the panel to display the 'View > Edit As' menu which can be used to choose a new Edit As for the current file.


  • Syntax (F) - (Text Only) - Displays which Syntax Highlighter is chosen for the current text file. If no Syntax Highlighter is chosen then this panel contains 'Plain'. Clicking on a Syntax Highlighter runs a Template and see Running Templates and Scripts for more information on Templates and the icons available at the top of the popup dialog.


  • Character Set (G) - Shows which character set is being used to display the current file. The character set depends upon the current Edit As (see Using Edit As) and can be controlled through the 'View > Character Set' menu option. The following character sets are available by default:

    • ASCII - ASCII Character Set
    • ANSI - ASCII+ANSI Character Set
    • OEM - ASCII+OEM Character Set
    • EBC - EBCDIC Character Set
    • UNI - Unicode Character Set
    • UTF8 - UTF-8 Character Set
    • MAC - Macintosh Character Set
    • ARA - Arabic Windows Character Set
    • ARA-I - Arabic ISO Character Set
    • BAL - Baltic Windows Character Set
    • BAL-I - Baltic ISO Character Set
    • CH-S - Chinese Simplified Character Set
    • CH-T - Chinese Traditional Character Set
    • CYR - Cyrillic Windows Character Set
    • CYR-R - Cyrillic KOI8-R Character Set
    • CYR-U - Cyrillic KOI8-U Character Set
    • CYR-I - Cyrillic ISO Character Set
    • EEUR - Eastern Europe Windows Character Set
    • EEUR-I - Eastern Europe ISO Character Set
    • GRE - Greek Windows Character Set
    • GRE-I - Greek ISO Character Set
    • HEB - Hebrew Windows Character Set
    • HEB-I - Hebrew ISO Character Set
    • JAP - Japanese Shift_JIS Character Set
    • JAP-E - Japanese EUC-JP Character Set
    • KOR - Korean EUC-KR Character Set
    • THAI - Thai Character Set
    • TURK - Turkish Windows Character Set
    • TURK-I - Turkish ISO Character Set
    • VIET - Vietnamese Character Set

    If the current file contains a Byte-Order Mark (BOM) this panel will contain '+B' after the character set name. The character set list and the text displayed in the status bar for each character set can be modified using the Character Set Options dialog. Left-clicking on this panel displays the 'View > Character Set' menu with the addition of a Convert to menu which can be used to quickly convert the character set to other recently used character sets. Clicking the More menu option at the bottom of the Convert to menu brings up the Convert dialog box.


  • Linefeeds (H) - (Text Only) - If the current file is a text file, the current type of linefeeds is displayed. The following linefeed types are supported:

    • CRLF - DOS Linefeeds (CR+LF - 0x0D0A)
    • LF - Unix Linefeeds (LF - 0x0A)
    • CR - Macintosh Linefeeds (CR - 0x0D)
    • NEL - Next Line (0x15 in EBCDIC or 0x0085 in Unicode)
    • FF - Form Feed (0x000C in Unicode)
    • LS - Line Separator (0x2028 in Unicode)
    • PS - Paragraph Separator (0x2029 in Unicode)

    Left-click the panel to easily convert all the linefeeds in a file to a particular type. Click the 'Tools > Convert' menu option to access the Convert dialog and other conversion options.


  • Tabs (I) - (Text Only) - This panel displays TAB if 'View > Tabs/Whitespace > Insert Tabs' is enabled or SPC if 'View > Tabs/Whitespace > Insert Spaces' is enabled. Following either TAB or SPC is the number of characters per tab stop in the file. Clicking this panel brings up a popup-menu which can be used to control the tab settings and this menu can also be accessed by clicking the 'View > Tabs/Whitespace' menu option. See the View Menu for more information on other tab settings.

  • Endian (J) - (Hex or Unicode Only) - Indicates which endian is used to interpret the current file. LIT means little endian (e.g. Intel machines) and BIG means big endian (e.g. Motorola machines). See Introduction to Byte Ordering for more information. Left-click on this panel to toggle between big or little endian mode. A tool button for changing endian can also be displayed in the Tool Bar using 'View > Tool Bars > Endian'. 010 Editor can visually swap bytes in the Hex Editor Window without modifying the underlying data. This swapping only occurs in little endian mode and when swapping is enabled this panel will display LIT<> (see Swapping Bytes for more information).

  • Clipboard (W) - A total of 10 clipboards are available for copying and pasting data. This field indicates which clipboard is currently selected. A 'W' means the default Windows clipboard is active and the numbers '1' through '9' indicate that a user clipboard is active. See Using the Clipboard for more information. Left-clicking this panel shows the 'Edit > Clipboard' menu.

  • Insert Mode (X) - Displays whether the editor is in Insert (INS), or Overwrite (OVR) mode. Press the Insert key or click this status bar panel to toggle between the two states. This mode is used when editing data in the editor or when pasting data from the clipboard (see Using the Text Editor, Using the Hex Editor and Using the Clipboard for more information). The cursor in the Editor Window will display as a thick line when in Overwrite mode or a thin line when in Insert mode.

For long operations, a progress bar will usually be displayed in the Status Bar. In most cases, pressing the Esc key will cancel the operation.


This is the manual for 010 Editor, a professional hex editor and text editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v12.0.1 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com