Edit Anything

Professional text and hex editing
with Binary Templates technology.






010 Editor - Text/Hex Editor Homepage

The Editor Options dialog is used to modify options that affect both the Hex Editor Window and the Text Editor Window. Open the Editor Options dialog by clicking 'Tools > Options...' and selecting Editor from the list.


Creating Files

  • Default New Edit As - When a file is created by clicking the New icon in the Tool Bar, the created file is assigned an Edit As (see Using Edit As for more information). Select which Edit As the created file should have from the drop-down list.

  • Manage New File Types - Clicking this button displays the Manage New File Types dialog as shown above. This dialog controls which entries appear in the 'File > New' menu or the menu accessed by clicking the down arrow to the right of the New icon in the tool bar. The Name column controls which text appears on the menus and the Edit As column controls which Edit As is assigned to the file after it is created. A Syntax Highlighter can also be assigned to the file when it is created using the Syntax column. Click the '+' icon to create a New File Type, the 'x' button to delete a New File Type, or the arrow keys to move a New File Type up or down in the list. Shortcut keys can be assigned to the different New File Types using the Shortcut Options dialog.


Opening Files

When a file is opened in 010 Editor, the file is assigned an Edit As based on the masks in the Edit As Options dialog. If no mask matches the file name, 010 Editor can automatically try to detect the correct Edit As (select Auto-Detect Edit As) or 010 Editor can assign a specific Edit As (select Use Edit As and choose the Edit As from the drop-down list). When the Remember Last Used Edit As toggle is set, 010 Editor will remember the last used Edit As, Endian, Character Set and Word Wrap setting for a file last time it was closed and will restore those settings when the file is opened again. If the Remember Last Cursor Position toggle is enabled then the last cursor position and scroll bar position will be restored to their previous values when 010 Editor is closed and reopened.

When opening a Windows shortcut .LNK file, 010 Editor can either automatically open the target file specified in the LNK file, or the LNK file itself. If Ask to Open Target or LNK is chosen then a dialog pops up each time an LNK file is opening asking to either open the Target or the LNK. If Open Target is chosen then the target is extracted from the LNK file and opened, and if Open LNK is chosen then the original LNK file is opened and no dialog is displayed. The displayed popup dialog has a toggle Always use this option which can be checked to remember the chosen option and the chosen option can also be changed through this Option dialog page. Note that not all LNK file formats are supported and a warning message is displayed in the status bar if an unsupported LNK is opened.


Closing Files

  • Hide Floating Tab Group when All Files are Closed - When all tabs are closed in the Floating Tab Group, it will automatically be hidden if this toggle is enabled. If this toggle is turned off, an empty Floating Tab Group will be displayed when all tabs are closed. The Floating Tab Group can be displayed by clicking 'View > Floating Tab Group' on the main menu.

  • Show Startup Page when All Files are Closed - When this toggle is enabled and all files are closed in the editor, the Startup Page will automatically be shown. If this toggle is disabled then a blank interface will be shown when all files are closed and right-click on the blank interface and select 'Startup Page' to display the Startup Page.


Highlighting

  • Highlight Current Line - By default, the line the cursor is on in the Editor Window will be highlighted a yellow color. When this option is turned off, the highlight will no longer be displayed. Note that the color of the line can be controlled from the Theme/Color Options dialog.

  • Show Inactive Caret - When an editor is not currently focused, a vertical gray line will appear where the cursor was. This line is called the Inactive Caret and can be disabled by turning the Show Inactive Caret toggle off.


Scrolling

  • Mouse Wheel Scroll Speed - If your mouse is equipped with a scroll wheel, the Editor Window can be scrolled by rolling the wheel forward or backward. By default, for every click of the wheel the window scrolls two lines; however, to change the scroll speed enter a value in the Mouse Wheel Scroll Speed field. Higher values scroll faster and lower values scroll slower.

  • Show Shadow when Horizontally Scrolled - When a Text Editor or Hex Editor is scrolled to the right, some themes display a Scroll Shadow line along the left side of the editor to indicate the editor has been scrolled. This shadow can be disabled by unchecking this toggle and the color of the shadow can be controlled with the Theme/Color Options dialog.


Input Method Editors

  • Allow Input Method Editors (IMEs) (Linux Only) - Input Method Editors (IMEs) are special in place editors designed for entering non-ASCII characters into an editor. On some versions on Linux, IMEs can cause issues with the editor and are turned off by default. To re-enable IMEs click the Allow Input Method Editors (IMEs) toggle.

The Reset button can be used to return all of the Editor Options to their default values.


This is the manual for 010 Editor, a professional hex editor and text editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v12.0.1 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com