Edit Anything

Professional text and hex editing
with Binary Templates technology.






010 Editor - Text/Hex Editor Homepage

010 Editor contains a number of themes which are a set of colors for all the various user interface elements in the program. Some themes have dark backgrounds, called dark themes, and some themes have light backgrounds, called light themes. The Theme/Colors Options dialog allows choosing a theme and a theme can also be chosen in the Welcome dialog displayed when 010 Editor is run for the first time. Open the Theme/Color Options dialog by clicking 'Tools > Options...' and selecting Theme/Colors from the list. Styles for all the Syntax Highlighting rules are also controlled by this dialog. New themes can be created and the individual colors in the themes can be customized. The following themes are available:

  • Starry Sky - The default theme with a darker background which some users may find gives less eye strain when used in low-light conditions (nighttime).

  • Morning Sky - The standard light theme with a white background.

A number of themes from older versions of 010 Editor are available for users who prefer the older styles:

  • Evening Sky - A dark theme with a dark gray background and blue tabs.

  • Blue Sky - A light theme with a white background and blue tabs.

  • Rain Cloud - Identical to Blue Sky except the tabs are displayed as gray.

  • Day & Night - Uses a light theme for the editor and a dark theme for the application background.

  • Midnight - Similar to Evening Sky except the background is black.

  • Classic - A theme used in old versions of 010 Editor.

If a theme has been imported using the Import... button at the bottom of the dialog then a new theme named Custom will also be available in the list followed by the file name of the theme in brackets. Clicking the Export... button will save the current theme to a file including any modified colors.

Some user interface elements are drawn using a native style, meaning the operating system draws those elements using its standard drawing procedures (for example the Mac menu bar and the Mac status bar are always drawn by the operating system). 010 Editor overrides some of this drawing with its own user interface styles but the native style can be turned on for some elements by clicking the Options button and turning on native drawing for either the Dialogs, Menu Bar, Tool Bars, Tool Buttons, Dock Headers (the title above each dock window), File Tabs, the Dock Window tabs, Table Headers or Scroll Bars. By default, tabs and headers are drawn with rounded corners but this can be disabled by unchecking the Rounded Tabs or Rounded Headers options. Also when switching themes when individual colors have been modified by the user, 010 Editor will ask whether to Reset the modified colors or to Keep the modified colors. If the Reset Colors when Switching Themes option is set to Ask then a dialog is displayed asking for the user choice but if the choice has already been set the Reset Colors when Switching Themes option will be set to Yes or No.

The Colors table allows customizing individual colors in each theme. Click the color box in the Fore column to set the foreground (text) color of the item or click the color box in the Back column to set the background color of the item. If a color has been modified the color name is drawn in Bold and a Reset button appears in the Reset column. Clicking the Reset button returns just that color to its original value. Some colors may be set to None, which means that the foreground or background color will be inherited from what is drawn behind the element (or in some cases setting to None means the default operating system color will be used instead). Some colors may also include a percentage which represents the Opacity: a value of 0% means full transparent and a value of 100% means fully opaque. When an Opacity is chosen between 0% and 100% then the color is blended with the background color.

Click on a color box to open up the Color Selector Box. Select a color from the box, or click the More Colors... button to open the standard Color Selector Dialog. When using the Color Selector Dialog, select a color from either the color boxes on the left or the color area on the right and click the OK button. Clicking the Add to Custom Colors button adds the current color to the list of 16 colors on the bottom left and this list is also displayed at the bottom of the color selector. If the color has an Opacity then a slider at the bottom of the dialog can be dragged to adjust the Opacity percentage. The Cancel button will close the dialog without selecting a color.

The following lists each of the color options and what they control. Note that when each color is changed the results usually are updated in the application immediately, making it easier to see how color changes will affect the application.


Application Colors

  • Application - The color of the main 010 Editor application window.

  • Dock Header - Sets the color of the header of the top of each Dock Window. Dock headers can be drawn using the system (native) style by using the Options drop-down menu.

  • Dock Header Highlighted - When the mouse hovers over a Dock Window header, the header is changed to this color.

Menu/Right Click Menu

  • Menu/Right Click Menu (Windows only) - Sets the text and background color of a popup menu that is shown by clicking the Menu Bar at the top of the application or by right-clicking on the editor. If Native Dialogs is turned on in the Options drop-down list then the system default colors are used for this and the following colors.

  • Menu Item Disabled - The text color of a disabled item in the menu.

  • Menu Item Highlighted - Controls the text and background colors of a menu item when the mouse hovers over the menu item.

  • Menu Separator - The color of a horizontal separator line in the menu.

  • Menu Outline - Sets the color of the outline box around the popup menu.

  • Menu Checked - The color of a rectangle drawn behind a checkmark or icon when it is checked in the menu.

  • Menu Bar - Controls the color of the Menu Bar at the top of the application window. A color of None means the default operating system colors are used. If Native Menu Bar is checked in the Options drop-down list the system default colors are used for this color and the following colors.

  • Menu Bar Selected - When the contents of a Menu Bar item are being displayed (for example, the File menu) the Menu Bar item is displayed using this color.

  • Menu Bar Highlighted - When the mouse is hovered over a Menu Bar item that item is displayed using this color.

Dialogs

  • Dialogs - Controls the text and background colors of dialogs in the application. If Native Dialogs is checked in the Options drop-down list then the system-default method of drawing dialogs is used.

  • Entry Field - Sets the text and background color of text-entry fields such as edit boxes.

  • Entry Field Outline - The color of the outline box around text-entry fields when not focused.

  • Entry Field Focus - The color of the outline box around text-entry fields when the field has input focus.

  • Entry Field Highlight - The color of the outline around entry fields when the mouse is placed over the field.

  • Tool Tip - The text and background color of tool tips or hints that popup when the mouse is hovered over an icon or certain other widgets for a few seconds.

  • Tool Tip Outline - Sets the color of the outline box drawn around tool tips.

  • Button - Controls the text and background color of buttons in dialogs.

  • Button Outline - The color of the outline box drawn around buttons.

  • Button Focus - The color of the box drawn around a button when the button either has input focus or is the default button (pressing the Enter key activates the default button).

  • Button Highlight - Sets the outline and background color of a button when the mouse is hovered over the button.

  • Highlight - Specified the text and background color of text that is highlighted in a text field. This color is also used to indicate the selected row in a drop-down list.

  • Link - Sets the color of HTML links in certain dialogs.

  • Message Box - On Windows, message boxes are drawn with a bar at the bottom of each message box. The background color indicates the color of the bar and the foreground color indicates the color of the line drawn at the top of the bar.

  • Group Box - On Windows, specifies the color of the box drawn around group boxes.

  • Lines - Sets the color of various lines used to separate widgets in dialogs.

  • Disabled Text - Use the Opacity slider to adjust how much blending is done between disabled text or buttons and the background of the control. An opacity of 0 means disabled controls are fully transparent and an opacity of 100 means disabled controls are fully opaque.

  • Item Selected - Sets the background color of items in a list when the list has focus.

  • Item Inactive Selected - Sets the background color of items in a list when the list does not have input focus.

  • Item Highlight - Controls the background color of items in a list when the mouse is placed over an item.

  • Item Header - Certain lists have header items (for example the list in the Template Repository dialog) and this color controls the text and background colors of the header items.

Tool Bar Colors

  • Tool Bar - Controls the color of the Tool Bars. The foreground color sets the color of the handle and arrows in each Tool Bar. A color of None means the Application color is used instead. Tool Bars can also be drawn using native drawing with the Options drop-down menu.

  • Button Highlighted - Sets the color of Tool buttons in the Tool Bar and also other Tool buttons in the application when the mouse is over the button. The background color controls the background color of the button and the foreground color controls the outline. Tool buttons can be drawn on a variety of backgrounds so Opacity is used to blend the Tool button color with the background color. Click on a color and slide the Opacity slider to set the Opacity percentage. Tool Buttons can be drawn using native drawing with the Options drop-down menu.

  • Button Selected - When a Tool button is pressed in to display a popup menu, the button is drawn using this color.

  • Button Down - Controls the color of a Tool button when the button is pressed down on the Tool Bar, for example the Show Whitespace button or the Word Wrap button. The background color controls the background color of the button and the foreground controls the outline color. Tool buttons are drawn with Opacity meaning they are blended with the background color and the Opacity can be adjusted by clicking on the color and dragging the Opacity slider.

  • Text - When an Action is dragged into a Tool Bar using the Toolbar Options dialog which does not have an associated icon, the text for the Action is displayed in the Tool bar with this color.

  • Text Disabled - If an Action with no icon is placed onto a Tool Bar but the Action is currently disabled, the text is displayed in this color.

Status Bar Colors

  • Status Bar - The color of the Status Bar at the bottom of the Application. Note that on macOS the status bar background is always drawn using the native style.

  • Status Bar Highlighted - When the mouse hovers over a panel in the Status Bar, the panel is drawn using this color.

  • Status Bar Line - Controls the color of lines drawn between the status panels on some operating systems.

  • Status Warning - If an error occurs when performing an operation, an error message is sometimes displayed in the Status Bar. The color of the error message will be displayed as this color (by default orange).

Startup Page Colors

  • Startup Page - The foreground and background color of the Startup Page.

  • Highlighted Row - When the mouse hovers over an item in the Recent Files list that item will be displayed with this background color.

  • Fade - Controls the fade at the very top of the Startup Page. If this color is set to None then no fade is drawn.

  • Paths - Sets the color of the paths displayed at the right-hand side of the Recent Files list.

File Tab Colors

  • File Tabs - Controls the foreground and background color of the unselected tabs in the list of tabs used to choose the active file above each editor. A background color of None means the Application background color is used.

  • Selected Tabs - The selected (active) tab in the list of documents is drawn using this color.

  • Highlighted Tabs - When the mouse is hovered over a tab in the list of files that tab is drawn using this color.

  • Division Line - Sets the color of the line underneath the File Tabs.

Dock Window Tab Colors

  • Dock Window Tabs - This option controls the color of all unselected tabs in the main application when Dock Windows are docked together to create a set of tabs.

  • Selected Tabs - The color of the selected tab in the list of Dock Windows in the main application.

  • Highlighted Tabs - Controls the color of the tab in the Dock Windows which is displayed as highlighted when the mouse moves over the tab.

  • Division Line - The color of the separator line displayed immediately above the Dock Window Tabs.

Dock Window Colors

  • Dock Windows - Sets the default text and background color for the Dock Windows, which include the Workspace, Inspector, Output Windows, etc. A color of None means the Application color is used.

  • Workspace - Controls the text and background color of the Workspace. A color of None means the Dock Windows color is used.

  • Explorer - The text and background color of the Explorer. Setting the color to None uses the Dock Windows color.

  • Explorer Fields - Controls the color of text fields in the Explorer.

  • Functions - Sets the color of the Functions tab and a color of None uses the Dock Windows Color.

  • Output - The text and background color of the Output Windows. A value of None means the Dock Windows color is used. Note that changing this color will not affect any text already present in the Output Window.

  • Output Warning - Controls the color of warnings in the Output Window as a result of running a Script or Template. Note that changing this color will not affect any warnings already present in the Output Window.

  • Output Error - The color of any error messages display in the Output Window. Note that changing this color will not affect any errors already present in the Output Window.

Table Colors

  • Tables - Controls the foreground and background color of tables in the application, including the Inspector, Template Results, Bookmarks, Find Results, etc. A color of None means the Application color is used.

  • Header - Sets the color of the header at the top of a Table.

  • Header Outline - This option controls the color of the outline drawn around a Table header.

  • Header Highlight - When the mouse is placed over a header section and the header section can be clicked then is it drawn using this color.

  • Grid Lines - Sets the color of lines drawn between cells in a table.

  • Alternating Rows - Controls the color of every second row in any of the Tables.

  • Selected Row - The color of the currently selected row in a table when the table has input focus.

  • Selected Cell - Sets the color of a box drawn around the cell in a table which is currently focused. If None is chosen then the default operating system indicator is drawn instead.

  • Inactive Selected Row - Controls the color of the selected row in a table when the table does not have input focus.

  • Group Heading Row - The Group Heading row is a special row of data in a table to show the start of a block of information. For example in the Find In Files results the results for each file begin with a Group Heading row. This color gives the foreground and background color of the row.

  • Group Heading Outline - Controls the box around the Group Heading Row in a table and setting to None means that no box is drawn.

  • Edit - This color is used when a cell of the table is being edited, for example in the Inspector or the Template Results.

  • Paths - The text color used when displayed paths on the right side of the Workspace.

  • Highlighted Row - Some tables highlight the row the mouse is currently over (for example in the Workspace). The highlighted row is drawn in this color.

  • Indicator Closed - Sets the color of the arrow drawn beside an item in a cell when the item is closed.

  • Indicator Open - Sets the color of the arrow drawn beside an item in a cell when the item is open.

Graph Colors

  • Graphs - Controls the color of various graphs displayed in the Output Windows, such as the Find Results, Histogram Results, etc. The foreground color controls the box around the graph.

  • Find Item - The color a line in the Find Results graph which shows where a find occurrence is in a file.

  • Find Selected - Show which Find occurrence is currently selected in the Find table.

  • Find Marker - Beside the currently selected Find occurrence in the Find graph, two small arrows are drawn. This color controls the color of those arrows.

  • Compare Difference - Controls the color of a difference in the Compare results graph.

  • Compare Only In - The color of bytes that are only in one file in the Compare results graph.

  • Compare Selected - The outline of the range that is currently selected in the Compare results graph.

  • Histogram Item - Color of the bars in the Histogram results graph.

  • Histogram Alt Item - Every second bar in the Histogram results graph is drawn in an alternate color. This option controls the alternate color.

  • Histogram Selected - The color of the select bar in the Histogram results graph.

  • Process Read - Controls the color of heaps in the Process graph that are marked as read-only.

  • Process Read/Write - The color of heaps in the Process graph that are readable and writable.

  • Process Selected - Indicates the color of the currently selected heap in the Process graph.

  • Labels - Sets the color of text labels in the different output graphs.

  • Empty Graph - The color of a graph which currently contains no data.

App Bar Colors

  • App Bars - App Bars are thin bars displayed below an editor which are currently used for Find, Replace, Goto and Selecting a Range. This option controls the color of the App Bars and a color of None means the Application color is used.

  • App Bar Line - Controls the color of the line displayed above each App Bar. A color of None means no line is displayed.

  • App Bar Arrows - Sets the color of a number of upward facing arrows on the App Bar that popup additional panels.

  • App Bar Info Text - The color of an special information text on the App Bars (currently used for the hex-bytes display on the Find bars).

  • App Bar Splitter - Controls the color of vertical lines in the App Bar which can be clicked and dragged to resize sections.

Editor Colors

  • Editor - Indicates the foreground and background colors of the main Editor Window (see Using the Text Editor and Using the Hex Editor for more information).

  • Selected - After selecting a set of bytes (see Selecting Bytes), those bytes are drawn in a different color. By default, the text color is changed to white and the background to blue. Note that if text already has a foreground or background color, the selection is drawn with Opacity meaning colors for the selected bytes are blended into colors already in the editor. The amount of blending can be chosen by clicking the color and dragging the Opacity slider. A value of 100% means the selection color is fully opaque and 0% means transparent.

  • Highlight Line - By default, the line the cursor is located on will be drawn a different color which can be controlled with this option. The Highlight Line option can be turned on or off (see Editor Options).

  • Addresses - Specifies the color of the addresses along the left side of the Text Editor or Hex Editor Window. If set to None the Application color is used instead.

  • Addresses Line - The color of the line immediately to the right of the addresses. If this color is set to None then no line is drawn.

  • Addresses Hover Marker- When 'View > Addresses > Show Addresses' is off, a small vertical line is drawn at the left side of the address column when the mouse is placed over the address column. This option specifies the color of the line and to turn off the line display set the color to None.

  • Addresses End Marker- When 'View > Addresses > Show Addresses' is off, a triangle is displayed in the address column to mark the last line in the file. Set the color of the triangle using this option or set to None to hide the triangle.

  • Ruler/File Bar - Indicates the color of the ruler and the File Bar along the top of each Editor Window (when enabled). If set to None the Application color is used instead.

  • Ruler Line - Controls the color of the line underneath the Ruler. If set to None then no line is drawn.

  • Ruler Marker - The color of the small arrow which indicates the current column in the Text Editor Window ruler can be controlled with this option. The default color is gray.

  • Input Method Editor - Some languages use an Input Method Editor (IME) to insert characters into the Editor Window. When the IME is displayed, its color will be controlled by this option.

  • Caret - This option controls the color of the caret (the blinking cursor) in either the Hex Editor or Text Editor Window.

  • Inactive Caret - Sets the color of a line indicating the current insertion point even when an editor does not have any input focus. This is called the Inactive Caret and can be turned off using the Editor Options dialog.

  • Highlighting - This highlighting color is used when highlighting a set of bytes using 'View > Highlighting' (see Using Edit As for more information).

  • Bookmarks - Controls the color of Quick Bookmarks as displayed in the Text or Hex Editor, and any other bookmarks created when the Use Custom Color toggle is turned off in the Add Bookmark dialog.

  • Show Whitespace - When Show Whitespace is enabled for a text file, special symbols are drawn in the editor to indicate where space and tab characters exist. This option controls the color of the symbols that are drawn.

  • Wrap Line - A line can be drawn in the Text Editor to indicate where word wrap occurs by clicking the 'View > Linefeeds > Show Wrap Line' menu option. This option controls the color of the wrap line.

  • Breakpoint - Specifies the color of breakpoints in the debugger. Note that the foreground color is only used when 'View > Addresses > Show Addresses' is enabled.

  • Debug Active Line - Controls the color of the active line marker in the debugger. The foreground color is only used when 'View > Addresses > Show Addresses' is turned on.

  • Scroll Shadow - When a text editor or hex editor is scrolled to the right, a shadow line is drawn along the left-hand side of the editor to indicate that the editor has been scrolled. The shadow line is drawn in this color and is drawn with Opacity.

Hex Editor Colors

  • Modified - When bytes are modified in the Hex Editor, the colors of those bytes are changed. By default, the text color is changed to orange and the background color remains unchanged.

  • Alternating Hex Lines - When using the Hex Editor, alternating lines are displayed in a different color. Change this color to match the Editor background color to obtain a single color in the background.

  • Highlight Byte - When the cursor is in the left or the right editing areas, the current byte will be highlighted in the other editing area. The byte is colored light gray by default, but can be changed by clicking the color box.

  • Highlight Variable - After a Template has been run on a file, moving the mouse over the Hex Editor Window will cause brackets to display indicating where the template variables were declared (see Working with Template Results). The color of the brackets can be modified by clicking this color box. The Highlight Variable option can be turned on or off using the Hex Editor Options dialog.

  • Empty Area - The color to the far right of both editing areas in the Hex Editor Window can be controlled by clicking this color box. The default color is the color of the window.

  • Area Separator - The Separator is the line that separates the left area from the right area in a Hex Editor Window. Click this color to change the Separator color.

  • Division Lines - Division Lines are lines that are drawn on the Hex Editor Window that indicate groups of bytes. By default, Division Lines are drawn every 4 bytes and they are colored light gray. Use the 'View > Division Lines' menu to adjust the division lines (see Using Edit As). Clicking this color box allows changing the color of the Division Lines.

  • Sector Lines - Sector Lines are similar to Division Lines except they are usually used to visualize where sectors are located on a drive. Sector Lines can be controlled on the same menu as Division Lines 'View > Division Lines' (see Using Edit As). The color of the sector lines can be changed from the default dark gray using this color box.

  • Template Results Header - Controls the color of the header for the Template Results panel.

  • Template Results Line - The color of the line immediately above the Template Results header. Note that setting this color to None will remove the line.

Scroll Bars

  • Scroll Bars - Sets the background color of scroll bars in the application. If Native Scroll Bars is selected in the Options drop-down list then the system default colors for scroll bars will be used in the application, and if Native Dialogs is selected then the system default colors will be used for scroll bars inside dialogs.

  • Button - Controls the arrow color and background color of arrow buttons drawn in scroll bars.

  • Button Highlighted - The arrow color and background color of arrow buttons when the mouse is hovered over the button.

  • Button Pressed - The arrow color and background color of arrow buttons when the button is pressed down.

  • Slider - Sets the color of the main slider or handle of the scroll bar.

  • Slider Highlighted - The color of the slider when the mouse is hovered over the slider.

  • Slider Pressed - The color of the slider when the slider is pressed with the mouse.

  • Disabled - The background color of the whole scroll bar when the scroll bar is disabled.

  • Splitter Button - Sets the color of the small splitter buttons located just above or below the scroll bar on the right side of a Text Editor or Hex Editor. The foreground color specifies the outline color of the button.

  • Splitter Button Highlighted - The color of the Splitter Button when the mouse is placed over the button.

  • Splitter Button Line - The color of the line drawn between the Splitter Button and the scroll bar.

Mini Map

  • Mini Map - Controls the background color of the Mini Map which is a diagram drawn at the right side of each Text Editor or Hex Editor. The foreground color is only used when editing hex files to control the base color of bytes that have not been assigned a color.

  • Separator Line - Sets the color of the line drawn between the Mini Map and the rest of the editor. Hovering the mouse over this line turns the mouse cursor into a left-right arrow and clicking and dragging on the line can be used to resize the Mini Map.

  • Text Selection Box - When editing text files, a box can be drawn in the Mini Map that indicates which section of the Mini Map is visible in the Text Editor. By default the Text Selection Box is only shown when the mouse is over the control (the Opacity is set to zero) but change the Opacity to show the box at all times.

  • Text Selection Box Highlight - Controls the color of the Text Selection Box when the mouse is over the Mini Map.

  • Hex Selection Box - The Hex Selection Box is a rectangle drawn in the Mini Map to indicate which part of the Mini Map is visible in the associated Hex Editor. By default the Hex Selection Box is only shown when the mouse is over the Mini Map but the box can be shown by changing the Opacity to a non-zero value.

  • Hex Selection Box Highlight - Sets the color of the Hex Selection Box when the mouse is over the Mini Map.

  • Hex Highlight Line - When no selection is made in a Hex Editor, the line the cursor is on in the Hex Editor is highlighted this color in the Mini Map. If a selection is made in the Hex Editor then the highlighted line is not drawn. Note that for the Text Editor, the highlighted line color is taken from the editor's Highlight Line color above.

Find

  • Find Results - After clicking the Find All button in the Find Dialog (see Using Find), all occurrences in the file that match the target are colored according to this rule.

  • Find Selection Lock - When using the Find Bar or Replace Bar, it is possible to limit the Find or Replace to a selected range of bytes. When a Find or Replace is locked to a selection by clicking the Lock to Selection button in the Options dialog, the selection will then be drawn in this color until the range is unlocked.

Compare

  • Difference - After performing a comparison between two files (see Comparing Files), those bytes that are different between the files will be colored. This option controls which color will be applied to the bytes in the Hex Editor Window.

  • Only In - After a comparison between two files (see Comparing Files), bytes that are only in one file and not the other will be colored according to this rule.


Syntax Styles

Use the Syntax Style section to control the color scheme for all of the Syntax Highlighting rules. The use of styles allows multiple Syntax Highlighting rules to share a single color scheme (see Using Syntax Highlighting for more information). For example, both commenting in C++ and PHP share the 'code-comment' style. Changing the 'code-comment' style affects the colors of all rules that use that style. All styles that begin with 'code-' are typically used in programming languages while all styles that being with 'tag-' are used in tag-based (e.g. XML, HTML) languages. Syntax Styles can be assigned a different color depending on if they are being used for a dark theme or a light theme. When a Syntax Style is selected in the list a special group of icons appears at the top-right corner of the dialog:

Clicking the Plus icon creates a new style and clicking the X icon deletes the selected style. Note that some Syntax Highlighters automatically create syntax styles if they do not already exist. The Up and Down arrows can be used to move styles to a new position in the list. To rename a style double-click the style name in the list. Note that any created styles are marked as bold in the list and the Reset button will not appear beside the color when it is modified. Styles are exported automatically when the current Theme is exported using the Export... button. Styles can also be created in Binary Templates that do Syntax Highlighting if they call the HighlightFindStyle function.


Clicking the Reset button will return all of the colors to their default values but note that any created Syntax Styles will be kept but moved to the bottom of the Syntax Styles list.


This is the manual for 010 Editor, a professional hex editor and text editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v12.0.1 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com