Edit Anything

Professional text and hex editing
with Binary Templates technology.






010 Editor - Text/Hex Editor Homepage

The View Menu is used for controlling the current Edit As. The Edit As (which includes the Font, Character Set, Linefeeds/Line Width, Tabs, Addresses, Group By, Division Lines, Areas, Highlighting, Ruler, Mini Map and Status Bar) tells the program how each Editor Window should display data (see Using Edit As for more information). When one of the Edit As options is modified, this affects all files that use that Edit As (except for the Endian and Word Wrap setting as discussed below). The View menu will display different options when a text-based Edit As is active as opposed to a hex-based Edit As because some options are only applicable to one type of Edit As. By default, 010 Editor comes installed with a number of Edit As choices as displayed on the 'View > Edit As' menu; however, a new Edit As can be created for different files based on the file name or extension. Note that all Edit As options are saved automatically upon exit. The View Menu is also used to control which panels are displayed and controls options for the Tool Bars. This section lists all available menu options in the View menu:

  • Edit As > (Edit As List) - Shows a list of possible Edit As choices (see Using Edit As) that can be used to edit files. A check mark is placed beside the Edit As that is applied to the current file. To create a new Edit As use the 'Create New Edit As' or 'View Edit As List' menu option. The current Edit As is also displayed in the Status Bar and can be changed by clicking the Edit As name in the Status Bar.

  • Edit As > Toggle Hex Edit As - If editing a file using a text-based Edit As, clicking this option chooses a hex-based Edit As to edit the file. Similarly, if the current Edit As is a hex-based Edit As the file is switched to a text-based Edit As.

  • Edit As > Create New Edit As - Creates a new Edit As for all files with the same extension as the current file. For example, if the current file has a '.bmp' extension then all files that are opened with a '.bmp' extension will use the created Edit As and the Edit As will be named 'bmp' on the Edit As menu.

  • Edit As > View Edit As List - Displays the Edit As Options dialog that is used to modify, create, or delete Edit As settings.

  • Font - Sets the font for the current Edit As. This menu will display either Use Default Text Editor Font or Use Default Hex Editor Font depending upon if this Edit As is for text or hex files. If this toggle is enabled, the default font is used from the Font Options dialog, otherwise this Edit As uses its own custom font. Clicking Change Font displays the standard Font dialog that allows setting of the font type, size, and style. Use the Enlarge Font (Ctrl++) or Shrink Font (Ctrl+-) menu options to increase or decrease the size setting for the font. If this Edit As is using one of the default fonts, the Change Font, Enlarge Font and Shrink Font menu options affect the default font, otherwise these options affect the custom font for this Edit As.

  • Character Set - This option controls which character set is used when displaying characters in the Text Editor or the character area of the Hex Editor. The list of character sets can be viewed and modified using the Character Set Options dialog. The Character Set menu lists the most commonly used character sets at the top of the menu (this can be controlled using the Show at Top Level toggle in the Character Set Options dialog), followed by a list of recently used character sets which are not on the common list. Next the menu lists the rest of the available character sets sorted into Standard, International and Custom categories. At the bottom of the Character Set menu is the Use Default toggle. When this toggle is turned on the character set is used from the current Edit As and changing to a new character set modifies all files that use that Edit As; however, when the Use Default toggle is off this file uses a per-file character set and changing the character set only affects the selected file. The Use Default toggle may be turned off automatically when opening a file if a different character set is detected than is set in the Edit As. See the Character Set Options dialog for more information about character sets. Note that the Endian setting can affect certain character sets such as the Unicode character set.

  • Linefeeds (text only) - Controls how a text file is divided into lines. Currently this menu is used to control how Word Wrap is applied to files. When Word Wrap is enabled, any lines that go beyond the edge of the Text Editor Window are wrapped onto a new line. Click the Word Wrap option to turn wrapping on or off (see Word Wrap for more information). Note that whether Word Wrap is turned on is stored separate to the Edit As and the current Word Wrap state is remembered for files if the Remember Last Used Edit As toggle is set in the Editor Options dialog. If a file has not been opened before (or the Remember Last Used Edit As toggle is turned off), the wrap state can be set with the Initial Wrap State menu option to On, Off or Auto-detect. For Auto-detect, 010 Editor will automatically turn on Word Wrap if it finds the file contains long text lines. Wrapping is usually done at the edge of the Text Editor Window but can be set to occur at a specific column with the Wrap Width menu option. Wrapping can be set to Column 80 or any other column number by choosing Custom Column. When the Show Wrap Line menu option is enabled a line is drawn in the editor either at column 80 or the custom column position. Note that the wrap line can be turned on even when wrapping is not enabled. When applying Word Wrap, by default whole words are always kept together but wrapping can be done on any letter by choosing Wrap on Letters on the Wrap Method menu. Select Wrap on Words to return to keeping whole words together. The Column Mode menu item switches the editor to or from Column Mode and see the separate Column Mode help topic for more information.

  • Line Width (hex only) - Specifies how many bytes are displayed on each line of the Hex Editor. For example, if Fixed 16 Bytes is chosen the file is displayed with 16 bytes per line. When the linefeeds are set to Auto Width the number of bytes to display is automatically chosen to fill the width of the Hex Editor Window. The width can be set to 4, 8, 12, 16, 20, or Custom Width. When setting to a Custom Width a dialog will be displayed for entering any width (values between 1 and 1024 are allowed). Note that the number of bytes per line must be divisible by the number of bytes in the Group By option.

  • Tabs/Whitespace (text only) - When editing a text file the columns of the file are divided into a number of tab stops. Enable the Show Whitespace menu option to display symbols indicating where all spaces, tabs and linefeeds exist in the file (the color of the symbols can be controlled using the Theme/Color Options dialog and the symbols displayed can be controlled using the Text Editor Options dialog). Choose the number of characters between each tab stop using the Tab Size: menu options (click the Tab Size: Custom menu option to set a specific tab size using an input dialog). When a tab character is encountered in a file the next character is drawn at the next tab stop. The number of characters to insert when the Tab key is pressed can be controlled through the Indent Size: menu options. Note that the Indent Size may be different than the Tab Size. If the Insert Spaces toggle is enabled (the default) spaces are inserted into a file to simulate the tab positions. To insert actual Tab characters enable the Insert Tabs option and make sure the Tab Size and Indent Size are set to the same amount. An easy way to access this menu is by clicking the Tabs section of the Status Bar.

  • Addresses - Controls the addresses for the current Edit As as displayed in the left-hand column of the Editor Window. If Show Addresses is off then no labels are displayed but the addresses will be shown in a hint popup when the mouse is placed over the address column for a second. The lower section of the Addresses menu controls the format of the addresses and can display either the Byte Number, Line Number, Sector Number or Short Number (note that a Short is a group of two bytes in a hex file). Some addresses can be displayed in either Hex, Decimal, or Octal format as indicated in brackets to the right of the address type. Note that when editing a hex file the line number displayed depends upon the number of bytes per row in the editor (set the Line Width option above). When Sector Number is chosen the address is displayed in the format '< sector number >|< sector offset >' (see Editing Drives for more information on sectors). If None is chosen no addresses are displayed for the file.

  • Group By (hex only) - When using a hex-based Edit As this option sets how many bytes are grouped together in the display. Bytes that are grouped together are displayed without spaces. The default value is Byte, meaning that each byte is displayed with spaces around it. A custom Group By value can be set by clicking the Custom option and entering a value. Note that the number of bytes per line (see Line Width above) must be divisible by the number of bytes per group. The Hex Editor Window has a special mode that allows groups of bytes to be visually swapped without modifying the underlying data. This mode can be enabled by clicking the Swap Little-Endian Bytes by Group toggle and choosing a Group By other than Byte. See Swapping Bytes for more information.

  • Division Lines (hex only) - When using a hex-based Edit As the Division lines allow drawing lines on the Hex Editor Window to visualize how data is grouped into sections. Currently there are two types of lines that can be displayed: Division Lines and Sector Lines. By default Division lines are displayed every 4 bytes of the file and are drawn in a light gray color (use the Theme/Color Options dialog to modify the color). The top portion of the 'View > Division Lines' menu is used to control Division Lines. Choose 1, 2, 4, 8, or Custom to set the division spacing, or select None to hide the lines. The 'Set Starting Division Offset' allows starting the division lines on an address other than the beginning of the file. This feature is useful if your file contains a header at the beginning of the file and then a number of fixed size records (the starting offset can be used to skip over the header).

    Sector Lines are meant to visualize the sectors of a hard drive (usually 512, 1024, or 2048 bytes in size), but can be modified by the user to visualize other types of data when not editing a hard drive. By default, Sector Lines are displayed as dark gray lines but this can be modified in the Theme/Color Options dialog. Use the bottom portion of the 'View > Division Lines' menu to control the Sector Lines. Show or hide the Sector Lines by clicking the 'Show Sector Lines' menu option. When editing a hard drive, the sector size is determined from the physical device (see Editing Drives); however, when editing a regular file, the sector size can be user defined by clicking the 'Set Sector Size' menu option (this option is useful if you are editing a file which is an image of a drive). When a regular file is being editing a starting address for the sector lines can be specified using the 'Set Starting Sector Offset', similar to the Division Lines.

  • Left Area (hex only) - If the current Edit As is for hex-based files, this option controls which numeric format is used to display the bytes in the left side of the Hex Editor Window. The options are Hex, Char, Octal, Binary, and Decimal. See Introduction to Number Systems for more information.

  • Right Area (hex only) - When using a hex-based Edit As, this option controls which numeric format is used to display the bytes in the right side of the Hex Editor Window. The options are Hex, Char, Octal, Binary, and Decimal. As well, the Hide option can be selected to only display the left area.

  • Highlighting - Controls which bytes are highlighted in the current Edit As using a color scheme. When a color scheme is enabled by clicking on an item in the Highlighting menu, the background color of all bytes that match that scheme are modified. A check mark will appear beside an active highlight, and the highlight can be turned off by clicking on the highlight name again. Note that multiple highlights can be turned on at the same time (highlights at the top of the list take precedence over highlights at the bottom). The default Highlight options are 'Linefeed Characters' (0x0d and 0x0a), 'Alphanumeric Characters' (all letters and numbers), 'Control Characters' (any of the bytes from 0 to 31), and 'Non-ASCII Characters' (any of the bytes from 128 to 255). Custom highlights can be generated by clicking the 'Edit Highlights...' menu option (see Highlight Options for more information) and highlights can also be created for highlighting Shorts (a Short is a group of two hex bytes). Note that Syntax Highlighting is now applied using the Status Bar.

  • Ruler - The Show Ruler option controls whether the Ruler is displayed above each file. The ruler is a band with tick marks, indicating byte offsets from the first byte in a line. If Show Labels is turned off then no text labels are displayed on the Ruler but the text labels will be shown in a hint popup when the mouse is placed over the ruler for a second (both the mouse location and the current cursor position are shown). If Show Arrows is on then small arrows indicating the current mouse or cursor position are displayed in the ruler. The units used for the ruler labels can be set to hex or decimal using Hex Units or Decimal Units.

  • Mini Map - The Mini Map is an overview diagram displayed on the right side of a Text Editor or Hex Editor. Clicking Show Mini Map sets whether the Mini Map diagram is visible. Clicking Mini Map Options shows the Mini Map Options dialog which can also be accessed by right-clicking on the Mini Map.

  • Status Bar > File Position Units - Controls the format of the current cursor position as displayed in the Status Bar as either Byte Number, Line Number, Sector Number, or Short Number (a Short is a group of two bytes within a hex file). See Status Bar for more information.

  • Status Bar > File Size Units - Sets the format of the file size displayed in the Status Bar as either Byte Count, Line Count, Sector Count, or Short Count. Enable Include Commas to add commas to the file size after each group of 3 digits.

  • Status Bar > Selection Size Units - When a selection is made, the number of selected bytes is displayed in the status bar with the label Sel:. This menu option controls the format used to display the selection size.

  • Status Bar > Byte Value Units - The Status Bar displays the value of the byte the cursor is currently on. This menu controls whether the byte is displayed in decimal, hex, or binary formats. Choose None to hide the byte value.

  • Endian - Controls which byte-ordering is used for the current file (see Introduction to Byte Ordering). The ordering can either be Little Endian (Intel machines), or Big Endian (Motorola Machines). When the current file is in little endian mode, the Status Bar will contain the letters LIT and when the file is in big endian mode, BIG will be displayed (see Status Bar). Use the Toggle Endian menu option to switch between the two endians. The Endian setting is different than the other options in the Edit As since this option contains only the default Endian setting when a file is opened. Changing the Endian does not modify other files that are using the same Edit As (for example, you can have a big endian file and a little endian file open at the same time both using the Unicode Edit As).

  • Workspace Windows - Allows control over which tabs in the Workspace panel are visible. Click Show/Hide All Workspace Windows to toggle visibility of the Workspace tab and set all other tabs to the same visibility.

  • Inspector Windows - Hides or shows the tabs of the Inspector panel in the main window. To show or hide all of the tabs at the same time click the Show/Hide All Inspector Windows menu option.

  • Output Windows - Used to show or hide the different Output tabs including the Find Results, Find in Files, Compare, Histogram, Checksum, and Process tabs. Click Show/Hide All Output Windows to toggle the visibility of all Output tabs at once (the Esc key can also be pressed to hide the Output tabs).

  • Template Results - Toggles whether the Template Results panel is displayed at the bottom of the current Editor Window. See Working with Template Results for more information.

  • Floating Tab Group - Toggles the display of the Floating Tab Group as discussed in Using File Tabs.

  • Tool Bars - Allows control of which Tool Bars are displayed in the program.

  • File Bar - Controls which icons are overlaid onto the top-right corner of a Script or Template editor (see Overlaid Icons). The Run icon or the Repository icon can be turned on or off using the Show Overlaid Run Icon or Show Overlaid Repository Icon menu options respectively. When the debugger is active, a set of Debug icons are overlaid instead and these can be turned off using the Show Overlaid Debug Icons option. Older versions of 010 Editor used a File Bar above a Text or Hex Editor to run scripts and templates and control the repository. The old-style File Bar can still be displayed by enabling the Show Old File Bar menu option.

  • Other Windows - Allows display of other miscellaneous windows for 010 Editor: the Startup Page and the initial Welcome dialog.


This is the manual for 010 Editor, a professional hex editor and text editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v12.0.1 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com