Edit Anything

Professional text and hex editing
with Binary Templates technology.







010 Editor - Text/Hex Editor Homepage

Each file, process, or drive that is loaded in 010 Editor is placed into a File Tab as shown above. A collection of File Tabs in a single line is referred to as a Tab Group. By default all regular files that are loaded are placed into a single Tab Group in the main interface but all Scripts and Templates are loaded into a Floating Tab Group (see the Floating Tab Group section below).

The currently active File Tab will be displayed as bold and all file operations (save, close, find, select all, etc.) will be applied to that file. Each File Tab displays a shortened version of the full file name but the file name can be viewed in a hint popup by placing the mouse cursor over top of the Tab (the file name of the active file can also be viewed in the application title bar). Clicking on a File Tab sets that file as the active file in the application.

To close a File Tab either click the 'x' button on the Tab or click the middle mouse button on the Tab (some computer mice have a scroll wheel and a middle click can be performed by pressing down on the scroll wheel). Alternately, File Tabs can be closed using the 'File > Close' functionality. A popup menu can be accessed by right-clicking on the Tab. From the popup menu, click the 'Close' menu option to close the currently selected file or the 'Close All Except This' option to close all files except the file that is currently selected. Clicking the 'Copy File Path' option will place the full directory path of the current file onto the clipboard. See the File Menu for an explanation of other options on the popup menu.

If too many File Tabs are loaded to be viewed all at once, the File Tabs can be viewed by clicking on the left and right arrows (shown above) to scroll through the tabs. Clicking the down arrow displays a list of all File Tabs in that Tab Group.

File Tabs may be rearranged by clicking and dragging the tabs to new positions. An arrow will appear to indicate where a Tab will be positioned when dropped. File Tabs may even be dropped onto other Tab Groups (see Using Multiple Tab Groups below).


Using Multiple Tab Groups

By default all regular files are loaded into a single Tab Group in the main interface and all Scripts and Templates are loaded into a special Floating Tab Group (see the Floating Tab Group section below). The main interface can be split into multiple Tab Groups oriented either horizontally or vertically. When multiple files are loaded, multiple horizontal Tab Groups can be created by right-clicking on a File Tab and selecting Move to New Horizontal Tab Group. Another way to generate horizontal Tab Groups is to drag a File Tab towards the bottom of the Window until the blue selection area indicates the lower half of the dialog (see the dialog below).

Similarly, multiple vertical Tab Groups can be generated by right-clicking on a Tab and selecting Move to New Vertical Tab Group or by dragging a File Tab to the right until the blue selection area indicates the right side of the window.

Once multiple Tab Groups have been created simply drag a File Tab between the groups. Clicking the 'Window > Merge All Tab Groups' will place all tabs into a single Tab Group again. See the Window Menu for more information.


Floating Tab Group

The Floating Tab Group is just a floating window that contains a set of File Tabs and can be displayed by clicking the 'View > Floating Tab Group'. Any file can be moved to the Floating Tab Group by dragging the File Tab to the window until a blue selection area appears and then dropping the Tab. Note that the active file for the application will be marked as bold and only one file at a time can be the active file. Hide the Floating Tab Group easily by pressing the Esc key (the Esc key is also used to hide the Output window). When all tabs in the Floating Tag Group are closed, the Floating Tab Group will automatically be hidden but this behavior can be turned off using the Editor Options dialog.

By default all Scripts and Templates that are loaded are placed into this Tab Group but they can be set to load into the main interface by using the Compiling Options. Usually the Floating Tab Group is displayed on top of the application but it can be docked by right-clicking on the window and enabling the Allow Docking menu option.


This is the manual for 010 Editor, a professional hex editor and binary file editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.