Edit Anything

Professional text and hex editing
with Binary Templates technology.







010 Editor - Text/Hex Editor Homepage

Importing and Exporting allows conversion between a binary file and a number of supported formats. When importing or exporting files, the following formats are supported:

  • Hex Text - Stores a binary file as a text file containing a series of bytes in hexadecimal format. For example, the hex bytes 0x3F and 0x61 would be stored as the characters "3F 61"

  • Decimal Text - Stores a binary file as a text file where each byte is converted to a decimal number. For example, the hex byte 0xFF would be stored as the characters "255".

  • Binary Text - Stores a binary file as a text file where each byte is converted to a binary number. For example, the binary byte 0x6F would be stored as the characters "01101111".

  • C Code or Java Code - Converts a binary file to an array of bytes that could be included in a C/C++ or Java program. (When importing data, specify the import type as 'Source Code' and 010 Editor will automatically detect whether the data is C or Java code).

  • Intel 8, 16, or 32-Bit Hex Code - Stores a binary file in the Intel Hex format. A number of different variations of the format exist, including 8-bit, 16-bit, and 32-bit. The Intel Hex format is used in a number of different applications and is commonly used with EPROMs.

  • Motorola S19, S28, or S37 Records - Motorola S-Record format is used for transferring binary files and is commonly used with EPROMs.

  • Text Area - Stores the currently selected bytes as text exactly how they are displayed in the hex editor, including addresses and both the left and right areas. For example:

        0030h: 3031 3233 3435 3637 3839 3A3B 3C3D 3E3F  0123456789:;<=>? 
        0040h: 4041 4243 4445 4647 4849 4A4B 4C4D 4E4F  @ABCDEFGHIJKLMNO 
        0050h: 5051 5253 5455 5657 5859 5A5B 5C5D 5E5F  PQRSTUVWXYZ[\]^_ 
        0060h: 6061 6263 6465 6667 6869 6A6B 6C6D 6E6F  `abcdefghijklmno 
        0070h: 7071 7273 7475 7677 7879 7A7B 7C7D 7E7F  pqrstuvwxyz{|}~ 
    

    Note that importing from this format is not supported.

  • Web Page (HTML) - Similar to the Text Area option above except that the data is stored in HTML format suitable for being placed on a webpage. Any coloring of the data is also recorded in the HTML data. Note that data can only be exported into HTML format (importing is not supported).

  • Rich Text Format (RTF) - Similar to the Text Area option above except the data is stored in Rich Text Format (also called RTF). This format is used by a number of word processors including Microsoft Word. 010 Editor includes all foreground and background coloring information with the RTF but note that some programs such as Microsoft Word do not support having background colors in RTF data. Exporting to HTML will retain both the foreground and background colors more reliably. Only export is supported for this format.

  • Base64 - Base64 is a method of encoding binary data so that it may be transferred between different systems without losing any special characters. This format is used when transferring attachments over email and other applications on the internet. Both importing and exporting are supported for Base64 data.

  • Uuencoding - Uuencoding is a method of encoding data similar to Base64 but with different parameters. Uuencoding is used for transferring attachments over email or newsgroups, as well as other applications. Importing and exporting are both supported for uuencoded data.

Importing Files

Files may be imported by clicking the 'File > Import Hex...' menu option. Select a file to import using the displayed file dialog box. By default, all files that can be imported will be displayed and the file type will be set to 'All Supported Import Types' but the file type can be changed to only display files of one type. Once the file is imported, it will be converted to a binary file and opened as a new file in the editor. Any of the above formats can be imported into 010 Editor except where indicated. 010 Editor contains some special functionality for importing Intel Hex or Motorola S-Records (see Opening Files for more information). The Directory Options dialog can be used to control the initial directory when the file dialog box is displayed.

When importing a file, any bytes that are skipped are set to zero value by default; however, this value can be changed using the Default Import Byte option in the Importing Options.

In some special Intel Hex files, the addresses specified in the file indicate the position of the Word where the data exists. To convert from this Word-based addressing system to a Byte-based addressing system, enable the Words toggle in the Importing Options dialog (internally, the addresses are multiplied by two). Note that leaving this toggle enabled when the import file does not use Word-based addresses will cause undefined results.


Exporting Files

To export the current file to one of the above formats, open the file and click the 'File > Export Hex...' menu option. The Export Hex dialog will be displayed.

Choose a file name for the exported file in the Export File field. A file name can also be chosen by clicking the Browse button to the right of the field. The default directory for the file to export can be controlled using the Directory Options dialog. Select which type of file to export using the Export Type drop-down list. Note that changing the export type automatically modifies the extension of the file to save. The number of bytes per line in the output file can be adjusted using the Bytes Per Row field.

To view advanced options for the file to export, click the Options button. Choose the Entire File radio button to export all the bytes from the current file or if a selection is made, choose the Selection toggle button to only export the selected bytes.

The Intel Hex and Motorola S-Records formats support specifying a starting address of the data. When the Always Zero toggle is selected, the address will always be written as zero. If the Start of Range toggle is selected, the starting address of the exported bytes will be written (this is usually zero unless a selection is exported using the Selection toggle). A custom address can also be specified by selecting the Custom toggle and entering a number in the corresponding text field.

When exporting Intel Hex files, the output addresses can set set to Byte-based addresses by selecting the Bytes toggle (the default) or to Word-based addresses by clicking the Words toggle. See the Importing Files section above for more information on Word-based addresses. If the Words toggle is enabled, the addresses will be divided by two when exporting.

Click the Export button to create the exported file, or the Cancel button to dismiss the dialog without exporting.


Importing or Exporting Data Through the Clipboard

A quick way of importing or exporting data exists in 010 Editor by using the clipboard. To quickly export data, select the bytes to export and click 'Edit > Copy As' and then select the type of data to export. The data will be exported and the results copied to the clipboard. Then the data can be pasted to another application (for example, copy data to the clipboard using 'Edit > Copy As > Copy As Web Page (HTML)' and paste the data into an HTML editor such as Microsoft Word). The data will be exporting using the same options as when the selected format was last exported using the 'File > Export Hex...' menu option.

Data can be imported quickly into 010 Editor by copying the data to import to the clipboard, then clicking 'Edit > Paste From' and choosing which format to import. The data will be imported and inserted into the file at the current cursor position.


This is the manual for 010 Editor, a professional hex editor and process editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.