Edit Anything

Professional text and hex editing
with Binary Templates technology.





010 Editor - Text/Hex Editor Homepage

Menus in 010 Editor can be customized using the Menu Options dialog. Access the Menu Options by clicking 'Tools > Options...' and choosing Menus from the list or by right-clicking on a Text Editor or Hex Editor window and choosing Customize... from the right-click menu.

All actions which can be placed on menus are located in the Actions tree. The actions are sorted into categories and double-clicking on a category name will show all actions in that category (e.g. File, Edit etc). Currently only the Editor Right-Click Menu can be customized (see Using the Text Editor or Using the Hex Editor) but other menus will be added in the future. To add actions to the right-click menu first locate an action to add in the Actions tree. Next click the action and with the mouse button pressed, drag the action onto the Editor Right-Click Menu and a red line will indicate the insertion point (see 1 below). Releasing the mouse button will add the action to the menu (see 2 below).

To delete an action from the menu, click the action name in the Menus area and then with the mouse button pressed down, drag the mouse out of the window (see 1 below) until the mouse cursor turns into a circle with a slash or an X. Release the mouse button to delete the action (see 2 below). Note that actions can also be dragged within a menu by clicking and dragging an action name in the Menus tree.

Two special items exist at the bottom of the Actions tree: Separator and Submenu. Dragging and dropping a Separator onto a menu will insert a horizontal line into the menu. Dragging and dropping a Submenu will add a new menu item that can function as a container for other actions. Submenu items have no action of their own but actions can be dragged into a submenu. When dragging and dropping an action onto a submenu, the regular red insertion line will turn into a red box around the submenu. Submenu items that contain children can be opened by clicking the icon to the left of the submenu name. To change the name of submenu double-click the submenu name, enter a new name, and then press the Enter key. When dragging a submenu item to a new location, all the children of the submenu will be moved as well.

Click the Reset button to restore the menu to its original state.


This is the manual for 010 Editor, a professional hex editor and binary editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v8.0.1 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com