Edit Anything

Professional text and hex editing
with Binary Templates technology.







010 Editor - Text/Hex Editor Homepage

The section lists all available menu options in the Edit menu:

  • Undo - Reverts the current file to the state before the last editing operation. The menu caption will change depending upon which operation was last performed. For example, if a block was pasted into the file, the menu will read 'Undo Paste'. All commands are stored on a stack so clicking Undo multiple times will undo the last editing operations in reverse order.

  • Redo - If an Undo operation was performed, the Redo menu option will perform the edit again (Redo is the opposite of Undo). The title of this menu option will change to indicate which editing operation will be redone (for example: 'Redo Edit', or 'Redo Script'). Click Redo multiple times will apply the last editing operations on the Undo stack in order.

  • Cut - If a set of bytes is selected in the editor, this menu option will remove the bytes from the file and place them on a clipboard (see Using the Clipboard for more information). Note that when editing drives or processes, the file size cannot be changed so Copy must be used instead of Cut.

  • Copy - The Copy menu option is similar to the Cut command except the selected bytes are copied to the clipboard but not removed from the file.

  • Copy As > Copy as Hex Text - Copies the current selection to the clipboard but converts the data from hex bytes to characters. For example, if the bytes 00 and FF were selected, 'Copy As Hex Text' would copy the characters '0', '0', 'F', and 'F' to the clipboard. This command is useful for copying binary data between 010 Editor and a text-only editor.

  • Copy As > Copy As (export_type) - This set of options allows copying the selection to the clipboard in any of the available export types (e.g HTML, RTF, Intel-Hex, etc.). Selecting one of these options exports the selection and then copies the results to the clipboard for easy transfer to another application. For example, select a set of bytes, click the 'Copy as Web Page (HTML)' menu option, switch to Microsoft Word or another HTML editor and paste the HTML directly into the application. Note that when the data is exported, all of the options are used from the last time that type of data was exported using the 'File > Export Hex...' menu option. See Importing/Exporting Files for an explanation of all export types.

  • Paste - If data has been copied onto the clipboard, the Paste command has two possible effects: When editing a text file or when in Insert mode (INS will appear in the Status Bar) Paste will insert the bytes on the clipboard into the file at the cursor position. When editing hex data in Overwrite mode (OVR will appear in the Status Bar) the bytes in the clipboard are pasted over the bytes in the file. If any bytes are currently selected in the file, those bytes will be deleted before the paste operation. To switch between Insert and Overwrite mode, use the Insert key. Note that the functionality of Paste can be controlled through the Hex Editor Options dialog (see Hex Editor Options for more information). When working with drives or processes, the file size cannot be changed so Paste will only work if the file size remains unchanged.

  • Paste Special - Some applications paste data to the clipboard in a number of different formats. The Paste Special command allows inserting of data to the current document in any of the available formats. See Using Paste Special for more information.

  • Paste From > Paste from Hex Text - This command is similar to the Paste command except that data is automatically converted from characters to hex bytes. For example, if the string "3f45" was copied onto the clipboard, the bytes 3f and 45 would be pasted into the file (note that extra characters included spaces are ignored). Paste From Hex Text is useful when copying binary data from other applications, such as a text editor.

  • Paste From > Paste from (import_type) - This set of commands provides an easy way to import information from data that is currently on the clipboard. Using one of these commands is the same as clicking the 'File > Import Hex...' menu option to import data, except that the data is read from the clipboard instead of a file. See Importing/Exporting Files for a list of all import types.

  • Delete - If a selection is made in the current file, the Delete menu option will remove the selected bytes from the file. When working with a drive or process, the file size is fixed so bytes cannot be deleted from the file.

  • Clipboard > (Clipboard List) - 010 Editor has a total of 10 possible clipboards, which includes the standard Windows clipboard plus 9 custom clipboards. All Cut, Copy, and Paste commands operate on the active clipboard (see Using the Clipboard for more information). The Clipboard menu indicates which clipboard is currently active by placing a check mark beside the clipboard name. Other clipboards can be selected by clicking on the list. The current clipboard is also displayed in the Status Bar.

  • Clipboard > Clear All Clipboards - Clears the data on all of the available clipboards. This command is useful to remove large blocks of memory on the clipboard that are no longer needed.

  • Select All - Selects all bytes in the current file.

  • Select Range - Shows the Select Bar at the bottom of the current editor that can be used to select a set of bytes in a file (see Selecting a Range for more information). If a selection is already made, the Select Bar displays the start address and size of the selection.

  • Insert/Overwrite > Insert File - Opens a file dialog box that can be used to insert a file into the editor at the current cursor position. See Inserting or Overwriting Files for more information. Files cannot be inserted into a drive or process since the file size is fixed.

  • Insert/Overwrite > Insert Bytes - Displays the Insert Bytes dialog that is used to insert a set of bytes into the current file. See Inserting or Overwriting Bytes for more information. Bytes cannot be inserted into a drive or process since the file size is fixed.

  • Insert/Overwrite > Overwrite File - Similar to the 'Insert Files' command except that once a file is chosen using the standard file dialog box, data from the selected file is written over the current file starting from the cursor position. See Inserting or Overwriting Files for more information. This operation can be used to write data to a drive or a process.

  • Insert/Overwrite > Overwrite Bytes - Sets all selected bytes to a single byte value. See Inserting or Overwriting Bytes for more information.

  • Insert Color - Opens a standard color selection dialog to select a color. After selecting a color and clicking OK the color is converted to a text string and inserted into the file at the current cursor position. By default the HTML color text format '#RRGGBB' is used but other formats can be specified with the Text Editor Options dialog. Note that 'RR', 'GG', and 'BB' represent the red, green, and blue color components in hex notation respectively.

  • Insert Date/Time - Converts the current date and time into a string and inserts the string at the current cursor position. The format of the date string can be controlled via the Text Editor Options dialog.

  • Set File Size - Allows setting the exact size of the current file through the Set File Size dialog (see Setting the File Size). The file size cannot be modified for drives or processes.

  • Read Only - Marks that no edits should be made to the current file. When set, 'Read Only' will appear after the file name in the title bar and a lock icon will appear beside the file name in the File Tabs.

  • Keep File Time - Marks that the file timestamp should not be changed when the file is saved to disk. 'Keep Time' will appear in the title bar when and a clock icon will appear on the File Tab beside the file name. Keep File Time only works for regular files and not for drives or processes.

  • Properties - Shows the Properties dialog, displaying information about the current file, drive, or process.


This is the manual for 010 Editor, a professional hex editor and disk editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.