Edit Anything

Professional text and hex editing
with Binary Templates technology.





010 Editor - Text/Hex Editor Homepage

The Window menu is used to manage all open files. This section lists all available menu options in the Window menu:

  • Duplicate Window - Opens another Editor Window that can be used to view the current file. The title of the window will change to include a ':' followed by a number to indicate that there are multiple windows open for the same file. Note that if a change is made in one file, the change will also appear in the additional view. See Opening Files for more information.

  • Split Window - Divides the current Editor Window into two areas, a top and a bottom area. These two areas can be used to edit two different portions of a file at the same time. The window can also be split by grabbing the small button above the vertical scroll bar in the Editor Window (see Using the Text Editor or Using the Hex Editor for more information). If the Editor Window has already been split into two areas, clicking this menu option will remove the split and display only one area.

  • Synchronize Scrolling - This menu option is a toggle that can be enabled or disabled by clicking on it. When the toggle is enabled and one Editor Window is scrolled up or down, then all other Editor Windows that are currently visible will scroll by the same amount. This option is useful to visually compare large sections of two different files. When using the Compare Files tool, an option exists in the Compare dialog to automatically enable Synchronize Scrolling after a comparison is run.

  • Synchronize Template Results Scrolling - Similar to Synchronize Scrolling except when this option is enabled and one Template Results panel is scrolled up or down, then all other Template Results panels that are visible will scroll by the same amount. One way to view multiple Template Results panels at the same time is to use multiple Tab Groups and see Using File Tabs for more information. Use this option when comparing the Template Results between two files and an option exists in the Compare dialog to enable this option after a comparison is done.

  • Next Window - Selects the next Editor Window in the interface as the active Window.

  • Previous Window - Selects the previous Editor Window in the interface as the active Window.

  • Move to New Horizontal Tab Group - If multiple Editor Windows are open, they may be separated into multiple horizontal Tab Groups. Selecting this option creates a new horizontal Tab Group and places the current Editor Window into that group. See Using File Tabs for more information on Tab Groups. If any Tab Groups are laid out vertically, they will be switched to horizontal.

  • Move to New Vertical Tab Group - Multiple Editor Windows may be separated into different vertical Tab Groups. This option creates a new vertical Tab Group containing the current Editor Window. See Using File Tabs for more information on Tab Groups. Clicking this option will change any Tab Groups laid out horizontally to be laid out vertically.

  • Move to Floating Tab Group - An additional Tab Group in a moveable window is available by clicking the 'View > Floating Tab Group' menu option. The current Editor Window can be moved to this Tab Group by clicking on this option (see Using File Tabs).

  • Move to Next Tab Group - If multiple Tab Groups have been created by clicking the 'Move to New Horizontal Tab Group' or 'Move to New Vertical Tab Group' menu options or by dragging the File Tab to a new position, this option can be used to move the current Editor Window to the next Tab Group.

  • Move to Previous Tab Group - This command is similar to the 'Move to Next Tab Group' option except the current Editor Window is moved to the previous Tab Group.

  • Merge All Tab Groups - Clicking the 'Merge All Tab Groups' option takes all open Editor Windows (including any Editor Windows in the Floating Tab Group) and places them into a single Tab Group in the main interface.

  • Window List - Displays a dialog containing a list of all open windows. Double-click on a window, or select a window from the list and click the Activate button to focus that window. Click the Cancel button to close the dialog.

At the bottom of the Windows menu a list of all open windows is displayed with a check mark beside the active window. Select a file from the list to activate that file.


This is the manual for 010 Editor, a professional hex editor and binary editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v8.0 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com