Edit Anything

Professional text and hex editing
with Binary Templates technology.



SweetScape Knowledgebase

KB1026: Will templates written in version 2 work in version 3?


Yes, it is our aim to always be backwards compatible with templates, so a template written in 010 Editor v2.1 should work fine in v3.0. The only issue is that there were some slight changes in how scoping of local variables worked as described in KB1025, but this should only affect a few templates.

With future versions we will always aim to be backwards compatible with templates; however, we are planning on adding new features to templates so beware that templates written with these new features will not work in older versions of 010 Editor. If you are using some new features in templates (these features should be marked in the help file), then you can use the 'RequiresVersion' function to ensure that your template is run using the proper version of 010 Editor.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v8.0.1 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com